Return to the Brugmansia Forum | Post a Follow-Up

 o
deformed leaves

Posted by charles_1959 (My Page) on
Sun, Apr 13, 14 at 3:48

Im a newbie and probably should know better Purchased New Orleans Lady from a cultivar and received a y cross section that looked pretty healthy until planting New leaves are deformed kind of "melted " looking Treated deformed leaves with the hydrogen peroxide solution and new leaves seemed pretty normal until a few days in, now back to the original dilemma


Follow-Up Postings:

 o
RE: deformed leaves

It sounds like you have some type of sucking insects on the bottom of the leaves. If you can't see them they are probably mites. Aphids should be visible. Either way a good dose of NEEM should probably help.


 o
RE: deformed leaves

Charles, can you upload a picture to give me a better idea? It could be a number of things.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here