Return to the Brugmansia Forum | Post a Follow-Up

 o
Brugs Help

Posted by Wayne1964 8 (My Page) on
Mon, May 13, 13 at 10:26

My Brugs are growing fine however, when it starts to put on a blossom the blossom starts to grow then turns yellow and falls off. What is causing that? Can it be Temp. related? Its been cooler than normal in TX, we get bouts of low temps in the 40's & 50's at night once in awhile? I fertilize it weekly and keep it watered regulary.


Follow-Up Postings:

 o
RE: Brugs Help

Bud blast maybe? Sounds like it at least.


 o
RE: Brugs Help

What is bud blast?
?


 o
RE: Brugs Help

  • Posted by tomr Z6 NY (My Page) on
    Thu, Jun 13, 13 at 7:37

Sometimes a change in temperature or location or humidity can cause the flower buds to die.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here