Return to the Brugmansia Forum | Post a Follow-Up

 o
What's Wrong with My CG?

Posted by MissMudPuppy z7 - L.I. (My Page) on
Thu, Jun 20, 13 at 12:25

Anyone know what's going on with my CG?
 photo 06-20-13_1206_zps73c08ddc.jpg

He was nice & green a month ago & now he's turned to this sickly looking light green with light veins.  photo Shocked_smiley_zps863641a8.png Tried giving him ES, MG, but no change. I have another Brug (FP) & I feed them both Dyna-Gro & Pro-Tekt but the FP doesn't have this problem.


Follow-Up Postings:

 o
RE: What's Wrong with My CG?

  • Posted by rednofl 9b Goldenrod Fl hz (My Page) on
    Fri, Jun 21, 13 at 6:14

Charles Grimaldi ? CG seems to run a lighter green / yellow than many of my other brugs.
Do you flush out the salt buildup that can happen in pots ?
My cure all is foliar spray Humic and fulvic acid, making sure plenty runs into the soil. It frees up minerals that are locked up in the soil


 o
RE: What's Wrong with My CG?

Thank you for your reply! Yes, it's a Charles Grimaldi :). Just got it 3 mos ago as a rooted cutting & it was a darker green than it is now which is why I was wondering if something was wrong or if this is just a characteristic of this particular Brug as it grows.
In answer to your ques: yes, I always make sure to flush out the pot before any feeding. It was recently potted up a wk ago since it already outgrew its 8" pot.

****EDIT****

Since my last posting, I decided to use the full strength dosage of Dyna-Gro Liquid Gro mixed with Pro-Tekt along with ST in a gallon of rainwater when it was time to water the Charles Grimaldi. 4 days later I gave it fish & seaweed emulsion. Added spent coffee grounds & egg shells to its pot & as of 3 days ago the new growth coming from the top is finally a lush gorgeous green again! Hallelujah! Looks like I need to feed this little piggy more than usual. So happy. Just thought I'd post this in case anyone else is having similar issues not related to watering/disease/pests/soil/etc.

This post was edited by MissMudPuppy on Mon, Jun 24, 13 at 21:14


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here