Return to the Brugmansia Forum | Post a Follow-Up

 o
new brug plant

Posted by shauntavia z8 GA (My Page) on
Sun, Jul 1, 12 at 12:47

Hi everyone....I recently ordered a new plant(can't tell you what specific one) but I ordered if online, and have had it about 3 months. It is about a foot tall. I have just noticed today, after watering yesterday that a lot of the bottom leave s have died and fell off. Is this normal or should I be worried? All the top leaves are still there and healthy. Also, how long does it usually take for these plants to bloom? I am in GA with 100 degree weather.


Follow-Up Postings:

 o
RE: new brug plant

Hi Shauntavia and welcome! Don't worry. It is normal for the older bottom leaves to turn yellow and fall off. I'm in NC, and I have a few brugs with blooms now, but most blossoms occur when temps are cooler, especially in the fall. Hope this helps!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here