Return to the Brugmansia Forum | Post a Follow-Up

 o
Immature Buds Shriveling Off Frosty Pink

Posted by MissMudPuppy z7 - L.I. (My Page) on
Thu, Aug 15, 13 at 8:05

Morning all. Pardon the long-winded explanation below but I wanted to include as much info as possible in the hopes some kind soul on here can help me figure out what's going on with my beloved Brug.

My 5 ft Brug bloomed beautifully last year. This year though has been a rough one. This spring I had to prune back almost all of its old branches after wintering because they had died. I knew it was going to set the tree back with blooming because most of the "Y's" had to be cut. After enduring over a month of temps in the 90's -100's, our temps have finally gone back to normal (it's in the 70's & 80's) & my Brug was finally able to start putting out tiny buds - only to have them dry up & fall off within a matter of days. It's been doing this for the past month & doesn't seem to be letting up.

It was repotted this spring in a 12 gallon pot. I've been feeding it once a week with MG & every 4-5 days after that with Dyna-Gro Liquid Grow 7-9-5. Both are mixed with rainwater. Leaves are lush & green but I noticed there's some mite damage going on now since the humidity dropped. Can that be causing the problems with the tiny buds shriveling up? I had mite issues last year too but it didn't prevent this Brug from producing buds & them maturing into blossoms. Hmmm...

It's funny but last year when I first got this tree, I had no idea what I was doing with it. I simply winged it & my plant grew & bloomed. It was put in organic garden soil in a pot & fed only MG & fish/seaweed emulsion once a week. It took off with no real issues that would impede its growth. This year I tried going by the book so to speak & have had nothing but problems. This Brug has grown back its branches & leafed out, but for some reason this year it can't grow its buds out without them shriveling up before they even get a chance to mature.


Follow-Up Postings:

 o
RE: Immature Buds Shriveling Off Frosty Pink

You are not alone. I have been growing and hybridizing brugs for over 10 years, and this has been the worst for mine also. My personal opinion is that it is the weather we had this year that has a lot to do with it. Mine also are at least a month behind in flushing, and they also set a ton of tiny buds that fall off. Many of the growers on another forum are having the same problem. Here in the north east we gad temps below freezing in June, then almost a month of excessive near 100* temps in July, and now, cool rainy weather in Aug. The brugs are confused, it's not you. Good thing is, now that the weather is getting back to near normal, I think we all will have at least 1 good flush in Aug/Sept. and, hope for better growing weather next year.


 o
RE: Immature Buds Shriveling Off Frosty Pink

I agree with Rudy. Mine have also been on a rollercoaster ride of weather this year. Although not the extreme high temperatures of 100 degrees, it has not let up with the rains.
It's drowning them.
This month the heat really kicked in and none of mine want to hold their buds either. I'm hoping for cooler weather by next month, and some good flushes by mid to late September.

It's not your care or lack of it (imho)
it's the weather.


 o
RE: Immature Buds Shriveling Off Frosty Pink

I had the same thing here on Long Island. We had a nasty heat wave in July, and lost all my buds just as you describe. I figured it had to do with the stress of the heat, brugs do not like it excessively hot, just like people. If we (people) are comfortable, then the brugs are comfortable. Once it cooled off, bud set was wonderful, and I am enjoying a strong blooming season now.


 o
RE: Immature Buds Shriveling Off Frosty Pink

My apologies for failing to acknowledge everyone's comments. Did not get any email notifications that anyone had responded to my query. Again, sorry!

rudy625: your Brugs are looking happy :). Whereabout are you in PA? I have family from Cheswick, Sagamore, & Moshannon. It's strangely comforting (?!) to hear that other growers have also been experiencing the same probs with their Brugs. Really hoping it's just a weather related thing. Even Cornell Co-op was mystified by what could be going on with my trees!

MsMorningSong: Sorry to hear you've had too much rain. Hope you get some nice flushes soon!

crocuscottage: I'm on the Island too (South Levittown). This summer has been one of the worst IMO! So happy you are finally enjoying some blooms :)!

I noticed my pink Brug put out a bud about 2" long but then it fell off. All the rest are still drying up & shriveling off :(. I think I'm going to give them just MG & seaweed from here on in & see if that helps any. My baby C. Grimaldi is starting to put out a bud so hopefully he'll be able to hold it. At this point, if I get ONE blossom this year, I'll be happy!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here