Return to the Brugmansia Forum | Post a Follow-Up

 o
please help my brug is loosing a ton of leaves and buds

Posted by MissKayle10-3-13 9 (misskayle32314@gmail.com) on
Tue, Aug 5, 14 at 15:03

I just got my first Angel's Trumpet about a month ago and since then its lost maybe 30 to 40 leaves and about 6 buds out of the 12 it began with. Its leaves have a spotted design on them and are turning from yellow to brown and will fall off regardless of color or appearance, and the buds are falling off when they are still green and havent opened yet. Ive been watering it every day due to our high temperatures we have been having (i live in california so our temps can get up to 110), ive also been putting a layer of manure on the top of the soil and feeding it with miracle grow liquafeed all purpose plant food once a week. I also fed it a epsom salt water mixture (1tbs to 1 gallon of water), but its still loosing alot of leaves and buds, please can someone help me figure out what im doing wrong?


Follow-Up Postings:

 o
RE: please help my brug is loosing a ton of leaves and buds

That looks like spider mites. I get them sometimes too when its gets very hot. I cut off all badly spotted leafs (they fall off anyways and look very bad) and then spray all the plant and especially under the leafs with soap and water with a spray bottle. Do this in the evening not in full sun. I spray and then wait for it to dry then I spray again and wait then I spray with the hose and wash the plant good and it gets rid of them. If it usually gets that hot in your area you should have yours in atleast morning sun and afternoon shade and I would spray it with the hose every few days just to keep any pests away.


 o
RE: please help my brug is loosing a ton of leaves and buds

I'll definitely give that a try, this is my first and only brug ive found after searching at our local nurseries for quite some time, so i hope this will help bring it back to health, thankyou so much for your help.


 o
RE: please help my brug is loosing a ton of leaves and buds

I'm pretty sure that will do the trick. But just incase you should spray it the next evening too to makesure you got everything off. And you should feed it so it grows quick and leafs out again nicely. I mostly only use miracle grow all purpose plant food the blue powder/crystals that dissolve in water. And it gets mine to grow fast and bloom. I also sometimes but not often at all use super thrive. Good luck and post pictures when it recuperates. Hope it flowers for you soon.


 o
RE: please help my brug is loosing a ton of leaves and buds

Well it is actually flowering nicely even though it only has less than half of the buds it had when i first got it, i even noticed that its a double once the first flower bloomed. I do have one more question for you though, it is still in its nursery pot which is a 3.5gal pot, i want to transplant it but i was worried that it might affect the blooms from possible transplant shock, and also whether its healthy enough after loosing so many leaves due to the mites. So do you think its safe to transplant it now or should i wait?


 o
RE: please help my brug is loosing a ton of leaves and buds

I have transplanted plants in bloom and they do fine. I have found brugs to be really hardy when transplanting. Im not afraid to loosen up the root ball very good to transplant it. But since it's your first blooms I would wait for it to finish blooming then you can transplant it. Also its fine if you transplant it even though it was was attacked by spider mites. Congrats on your double brug it looks like a nice double white.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here