Return to the Brugmansia Forum | Post a Follow-Up

 o
Flowers

Posted by oxmyxing none (My Page) on
Mon, Aug 5, 13 at 18:44

Been growing brugs for 5 years now with no trouble. Now when the flowers come out on C. Grimaldi the are dark brown edged.
Anyone know what it is? Do I need a fungicide?

( Hi to all the old friends if they wonder into this room!)

cheers, Barry


Follow-Up Postings:

 o
RE: Flowers

  • Posted by ednam z8 Virginia (My Page) on
    Tue, Sep 10, 13 at 20:39

OMG... Barry ! How are you, it's been years. Good to know your alive and well.

Edna


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here