Return to the Brugmansia Forum | Post a Follow-Up

 o
A brugmansia bloom, I can't believe it!

Posted by honeybunny2 Z9TX (My Page) on
Sun, Oct 9, 11 at 14:38

I went into the back yard to plant daylily plants that came in from Maryott's, I was carrying the dirt to the back, the smell was wonderful! I looked up and my original noid peach brugmansia had a few blooms. It has not bloomed for the past 2 years. Gosh, now I remember why I love this plant so much. Barbra


Follow-Up Postings:

 o
RE: A brugmansia bloom, I can't believe it!

Woohoo!!!


 o
RE: A brugmansia bloom, I can't believe it!

  • Posted by knotz 8/PNW SWWA (My Page) on
    Sun, Oct 9, 11 at 23:10

Nice!!


 o
RE: A brugmansia bloom, I can't believe it!

Congrats!:)


 o
RE: A brugmansia bloom, I can't believe it!

Congrats Barbra! Yesterday, I too experienced some wonderful perfume in the air from my Mountain Magic and a noid yellow that are blooming!


 o
RE: A brugmansia bloom, I can't believe it!

  • Posted by ruthz DFW/TX (My Page) on
    Mon, Oct 10, 11 at 11:36

This morning I have my first 2011 bloom. It's on my double white Species.
It had buds in May but as the weather got hotter, they just dropped off.
Dr Seuss has buds now also.


 o
RE: A brugmansia bloom, I can't believe it!

  • Posted by chena z8 Texas (My Page) on
    Mon, Oct 10, 11 at 12:32

Congrats Barbara.. Now where are the pic's Girl!!!!

Kylie


 o
RE: A brugmansia bloom, I can't believe it!

Congrats on the blooms! :) now like Kylie says...where are pics? LOL We wanna see!

~Tina


 o
RE: A brugmansia bloom, I can't believe it!

I'd love to see too! I have 6 remaining brugs, I dug up and threw away my peach versicolor which had not bloomed in 2 summers, not even a y this year. It was my oldest and I will not miss it. My double peach has been cut back for the year as it had no y (and no blooms) either, but it's only 2. My Santa Rosa, 2 cherubs and Heloise are loaded with buds! Can't wait!


 o
forgot

Oh, I forgot the white noid which is also budding!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Brugmansia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here