Return to the Cacti & Succulents Forum | Post a Follow-Up

 o
Need Succulent ID

Posted by spapa none (My Page) on
Sun, Feb 9, 14 at 17:39

I purchased this succulent 6 months or so ago with several other "assorted succulents," but it is the only one that is not doing well. I have done many Google searches and seen succulents that looked similar, but nothing that looks quite like what I have. As you can see, it is alive, but it has not been growing new leaves upon losing old ones. The second stalk has just about nothing left. I'm hoping by identifying it, I can figure out how to care for it properly! I have attached photos.


Follow-Up Postings:

 o
RE: Need Succulent ID

Possibly Sedum burrito. Do you have any pix of it when it was new?


 o
RE: Need Succulent ID

Are you watering it too much?


Neysa


 o
RE: Need Succulent ID

Thank you for your responses! I signed up to get email alerts but never got any so I didn't know anyone responded. This is how the plant has looked since it was "new", minus a couple of leaves -- it was never in good shape. I don't think I was watering it too much before as I managed to keep it alive for several months, but after posting these I decided to see if water would help and that was a mistake. I started to see rot the next day so I cut off the top of the larger plant and am now waiting for that to callous over. Here is pic in better focus of just the top I'm working with now.

Also, I have several sedum burrito plants and I don't think that's it, it was a darker green although it has lightened over time, maybe from too little sun.

I did see a listing on eBay for a plant called Pachyphytum compactum that looked similar in coloration. Any possibility that's what this is?


 o
RE: Need Succulent ID

Here is another photo from the side.


 o
RE: Need Succulent ID

These other pix indicate to me that it does have Pachy in it ~whether a species Pachyphytum or an intergeneric with that~ remains to be seen. Good luck with its continued growth.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cacti & Succulents Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here