Return to the Cacti & Succulents Forum | Post a Follow-Up

 o
Help Jade serious problem

Posted by Drezden none (My Page) on
Fri, Mar 9, 12 at 0:03

I know the quality of this photo is horrible, but maybe you can identify what this disease or problem is?

http://i556.photobucket.com/albums/ss8/Scott61289/Jadehelp.png

It started out as a bunch of white dots on my leaves.. and now today after watering multiple leaves looked like this.. they are partially rotted or something, and this white stuff all over it.

Is this a fungal infection or something like that? How do I fix this??


Follow-Up Postings:

 o
RE: Help Jade serious problem

While it is difficult to tell from your picture, it does look like a fungal infection. You can get an anti-fungal from any Big Box store or garden center; just ask someone in the store.

The other thing that will help you posting pictures is to use one of the features in Photobucket. When you want to post a picture that you've uploaded to PB, simply click the 3rd item down on the list under the picture. You will see "copied" for a brief moment. Now go back to your post here at C&S and right click your mouse and select "paste". When you "Preview" your message you will see a picture and not link.


 o
RE: Help Jade serious problem

The other thing I neglected to mention is that if this is only on a leaf or two, just remove the affected leaves. I would spray only if you see other portions of the plant becoming infected. So why is this happening? Could be too much moisture (humidity) and and not enough air circulation. Just a thought...


 o
RE: Help Jade serious problem

1) Depot your plant - it's suffering from non-porous soil, too much watering, not enough warmth and not enough sun, but mainly the first two.

2) Get some perlite and cut your potting soil with 50% perlite and repot in fresh soil. Don't water for a few days (if then, depending on the condition of the roots). In those few days, spend some time here reading posts on jade / Crassula ovata, and plant nirvana will be yours.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cacti & Succulents Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here