Return to the Cacti & Succulents Forum | Post a Follow-Up

 o
Help with ID?

Posted by greendale 6B (My Page) on
Tue, Apr 29, 14 at 19:41

It is flowering, may we get a positive ID? And what happened to those brown leaf tips?

Thanks a lot.

 photo 012.jpg

 photo 011.jpg

 photo 010.jpg


Follow-Up Postings:

 o
RE: Help with ID?

It's an Aloe of some kind. I don't know abt the damage, could be sunburn or mechanical? Just guessing.

Congratulations on the bloom, good for you! Did you manage that indoors? If so, I'm jealous.


 o
RE: Help with ID?

I say it's a Gasteraloe, but I don't know which one.


 o
RE: Help with ID?

Yes, indoor only. It sits on a southern windowsill. Not mechanical damage as I have it for almost one year now.


 o
RE: Help with ID?

Chlorine, chloramine or fluoride in city water can do that.

tj


 o
RE: Help with ID?

Yes city water can be horrible for plants, i spoil my plants way to much and buy only purified water


 o
RE: Help with ID?

Yes city water can be horrible for plants, i spoil my plants way to much and buy only purified water


 o
RE: Help with ID?

Yes, xGasteraloe (cross between Gasteria & Aloe aristata). Maybe one named 'Cosmo'.


 o
RE: Help with ID?

I have an Aloe 'Flow' that looks very similar to that... but I agree. It's some sort of Aloe/gasteraloe hybrd of some sort.


 o
RE: Help with ID?

I have one of these and it is refered to as a Zebra Plant (Haworthia fasciata variegata) It's a winter grower and is dormmant in summer. I have one but it is much smaller and had not bloomed yet.


 o
RE: Help with ID?

thanks all. by compare the pictures on the net and this link. I got it from home depot too. I think it is xGasteraloe 'Cosmo'. Thanks

Here is a link that might be useful: same plant


 o
RE: Help with ID?

Sorry Kristy, that's not a Haworthia (of which I grow several). It's Aloe or GasterAloe, the bloom is wrong for Haworthias.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cacti & Succulents Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here