Return to the Cacti Gallery Forum | Post a Follow-Up

 o
First Echinocereus flower!

Posted by cactuspolecat Tasmania Aust (My Page) on
Mon, Oct 31, 05 at 15:42

The first Echinocereus flower for the season, I have only had this plant (and others you can see in the background) for a few months. My larger plants are slow this year to bud up.

Echinocereus laui
Image hosted by Photobucket.com

Cheers, CP


Follow-Up Postings:

 o
RE: First Echinocereus flower!

I think you are in for lots and lots of spectacular flowers from that collection.

Enjoy! Enjoy!

Al


 o
RE: First Echinocereus flower!

What a beautiful flower. I can't wait till mine flower. I'll be grinning from ear to ear.

Dawn


 o
RE: First Echinocereus flower!

Nice!
You have a good collection there! I would love to find an E.huitchicolensis plant somewhere, I have a picture of one that is fantastic...just cannot find the link sorry...but it looks like it should be an echinopsis hybrid, not an echino'.
I am looking forward to some more of your shots CP!!
Wazzimodo


 o
RE: First Echinocereus flower!

Very nice indeed CP!!! It's so cool you folks down under can post pics when most of our stuff here is going dormant!! :-)
Bill in SC


 o
RE: First Echinocereus flower!

Thank y'all for the nice comments, Wazzimodo... onf of the small plants in the background (mostly obscured, and to the right rear) is the plant you are talking about, it is now known as E. polyacanthus ssp. huitcholensis. no buds on that one either at this stage.
Yeah Bill, I know what you mean... I got to see all the nice flowers from you folks while I waited out the winter... It's nice to be able to return the favour. :)

CP


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cacti Gallery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here