Return to the Camellia Forum | Post a Follow-Up

 o
Aphids on Camelia

Posted by char35 Houston (My Page) on
Wed, Apr 28, 10 at 12:16

I had 2 camellias planted about a month ago. About 10 days ago, I noticed two stems had very droopy leaves, but green. Water did not correct the problem. It was extending down the stem. After several days I noticed what seemed to be Aphids(black) on those stems. I sprayed the plant with Orthene. The damage seems to have stopped, the leaves on those branch are falling off(green),and no new growth starting. The effected branches scratch green.
Should I cut the branch off or leave it alone? should I re-spray? If so, when?


Follow-Up Postings:

 o
RE: Aphids on Camelia

leave it


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Camellia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here