Return to the Camellia Forum | Post a Follow-Up

 o
Camellia buds don't open fully --flower blight?

Posted by lafu115 7A. No. VA (My Page) on
Sun, Apr 21, 13 at 13:40

I have a camellia "Lisa" that has bloomed fine twice before. This time the buds only opened partially and some buds have fallen off. The partially opened blooms are soft and squishy and there are a few brown spots on the outside of the buds. Is this flower blight? It's about two years old.

Right next to the Lisa camellia I have a Camellia Japonica Katie Supreme. I planted it two years ago (3 gal size) and it has never formed buds before this year. This year it formed buds and they finally started to open then it seemed to stop. I haven't seen any brown spots and no buds have dropped.

Any ideas about either problem? Anything I can do in the future to help prevent this?


Follow-Up Postings:

 o
RE: Camellia buds don't open fully --flower blight?

The first one sounds like flower blight. The second one could be but it also could be caused by wildy girating temperatures and-or soil moisture. I have had winters when well timed temp changes made the shrubs stop blooming and then they restarted several weeks to a month later.

There is not much one can do when Mother Nature interferes... other than plant camellias that bloom earlier (sasanquas for example) or later (one of the April Series for example).

See the link below for camellia flower blight info by the American Camellia Society.

Here is a link that might be useful: Camellia Flower Blight by the ACS


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Camellia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here