Return to the Camellia Forum | Post a Follow-Up

 o
Katie Supreme didn't bloom

Posted by lafu115 7 N. VA (My Page) on
Mon, May 7, 12 at 8:19

I planted several camellia the last two years and all bloomed on schedule their first year even if just a few blooms. One however went through an entire year without blooming. It is Camellia Japonica Katie Supreme. It had aphids a couple of times, resolved easily with Neem oil. It is was 3 gal size when I got it (from Camforest) and has grown. Is it likely it didn't bloom the first year because it was new -- and I just got really lucky with everything else (most of which are sasanqua and not japonica). Is there anything I can do to help ensure it blooms this year? Thanks!


Follow-Up Postings:

 o
RE: Katie Supreme didn't bloom

It's not at all unusual for newly planted camellias to take several years to adjust to a new environment and to acquire the maturity to bloom normally. Just be patient and wait. Provide adequate water during dry spells, but be sparing with the fertilizer. I think it's wise not to fertilize a camellia during its period of adjustment.


 o
RE: Katie Supreme didn't bloom

It would help if you monitor what exactly happened. For example, did the plant not produce flower buds? Or did the flower buds develop but never opened because they dried out or whatever. Each scenario has its own set of possibilities.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Camellia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here