Return to the Gardening in Canada Forum | Post a Follow-Up

 o
flowers and buds wilting on roses

Posted by Jen-bar 5a (My Page) on
Wed, Aug 15, 12 at 15:09

The flowers and buds are wilting on my Austin rose, Mary Rose. It is not Black Spot. Has anyone come across this. Could it be magnesium or trace mineral dificiency.
Jenbar


Follow-Up Postings:

 o
RE: flowers and buds wilting on roses

How do the leaves look? Trace element problems can be seen in the leaves. Do you stem die offs(which points to root problem)? Post a photo if possible. Also, when did you get your plant? Is it old, new?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Gardening in Canada Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here