Return to the Carnivorous Plants Forum | Post a Follow-Up

 o
plants looking bad

Posted by mo89 (My Page) on
Sat, Mar 3, 07 at 16:09

About a week ago I repotted my sundew, cobra lily, and vft all in seperate pots because they were all together in one really small terrarium. Now they all look like they are almost dead and i don't know what to do. I used peat moss and i was thinking about putting some sphagnum moss in the roots so they could breath better. Does anyone have any recomendations


Follow-Up Postings:

 o
RE: plants looking bad

More than likely you bought neglected plants ("Lowes Cube Of Death") and the shock of bringing them home and repotting set them back a bit. Don't change anything more. Provide stable conditions and wait it out. Look for new growth. If you see new growth, all will be well. Just keep moist, lit, and open to the air.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Carnivorous Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here