Return to the Carnivorous Plants Forum | Post a Follow-Up

 o
What's up with this sundew?

Posted by steventaylor (My Page) on
Thu, Jul 24, 08 at 19:06

My sundew stopped producing dew a while back and I noticed aphids on it. I got rid of the aphids but still no dew. It also doesn't seem to flower completely. The flowers will barely open and then die back. How do I fix this? Thanks for any help.


Follow-Up Postings:

 o
RE: What's up with this sundew?

How much light does it get? What kid of water do you give it? tap? Distilled? Rain?


 o
RE: What's up with this sundew?

What kind of soil are they planted on? The original one that came with it? You repotted it? What did you use if you did?

Not that it is really relevant but what species do you have?


 o
RE: What's up with this sundew?

Well, I've been using filtered water from my pur filter (i know, i know). I did repot it into a 50/50 peat, perlite mix.
It's in a terrarium under two 15w compact fluorescent lights, which I think is about the same light as a 100w bulb. Could it be just the water?


 o
RE: What's up with this sundew?

At this point it just may be set back a bit. Give it time to recover.


 o
RE: What's up with this sundew?

this happened to one of my sundews also... the only one that i do not know the species of. first it had aphids, then it had spider mites. i sprayed with malathion, which killed all of the bugs, but the plant never really recovered. most of it started rotting, so i cut it all back, leaving little baby plants that had been growing around, but those are starting to rot too, and i just don't know what to do! is it a lost cause? i also have drosera venusta, aliciae and pulchella x nitidula, all of which are thriving in the same environment. the later three all came from california carnivores, but the sick one came from plant it earth in san francisco. any advice on how to revive it?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Carnivorous Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here