Return to the Carnivorous Plants Forum | Post a Follow-Up

 o
weed in my CP?

Posted by OctopusInc none (My Page) on
Wed, Aug 22, 12 at 14:08

Hello,

I have recently planted several cups of chopped dry sphagnum, sand, and perlite with different CP seeds in each. However some of my cups are shooting this pictured plant up pretty vigorously. I can clearly see that it is not a product of any seeds I have sown. Anyone know what this is?


Follow-Up Postings:

 o
RE: weed in my CP?

Probably a weed.


 o
RE: weed in my CP?

def a weed.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Carnivorous Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here