Return to the Clivia Forum | Post a Follow-Up

 o
Help with Clivia Problem

Posted by teisa 10 (My Page) on
Tue, Apr 23, 13 at 2:45

I have a Clivia that seems to be failing. I lost 2 leaves (one on each side). Last time I repotted it seemed to have roots rotting. I went to HD to look for product to help roots. I was told to buy copper fungicide, will this help? If someone can please give me advice on this I would really appreciate it!!

-Teisa


Follow-Up Postings:

 o
RE: Help with Clivia Problem

Teisa, why isn't it in the ground? It would do so much better in the ground, imho. I hope you haven't lost it.


 o
RE: Help with Clivia Problem

Kay,
I don't know why but for some reason it puts my zone as 10! I forgot to change it before posting. But each time I post I have to manually change It, as it is actually 6. So I could not put it in the ground here in zone 6.

So after reading here, I found information that it is actually sulfur that stops rotting roots. So I bought some this morning and I'm just about to apply this and repot it. I was hoping I had a response from someone on how to apply it and what to do next. But it's not been very long. Ive got to do something quickly!!

-Teisa


 o
RE: Help with Clivia Problem

Teisa, I wonder how your clivia is doing. Also, what kind of mix is it in? The chunkier the soil, the faster water drains out and the lower the chances of root rot.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Clivia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here