Return to the Clivia Forum | Post a Follow-Up

 o
20 year old plant

Posted by hotpotatoe 9 Texas (My Page) on
Fri, May 18, 07 at 19:46

I have been dragging around this Clivia for 20 years. She has been with me longer than any other plant. I moved her last year and thought I might get a bloom this year, but she didn't bloom. I had always kept her in a pot but left her in the same spot to long and she rooted and the pot had to be cut away. Any suggestions?


Photo Sharing and Video Hosting at Photobucket


Follow-Up Postings:

 o
RE: 20 year old plant

  • Posted by dries South Africa (My Page) on
    Sun, May 20, 07 at 23:41

Your plant looks healthy. They do skip a season sometimes. I am sure they will flower as normal next season.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Clivia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here