Return to the Clivia Forum | Post a Follow-Up

 o
Growing Clivia from seed - HELP! Fungus

Posted by driftwoodtx 10 - Los Angeles (My Page) on
Mon, May 24, 10 at 23:19

This is the first year I decided to grow Clivia from seed. I read every forum I could find in selecting what I needed to do. Right or wrong, here is what I did:

I gathered about 200 seeds from my various plants. I intended to place them in clear disposable plastic containers (6x6x2) in between wet paper towels. Before doing that, I put each seed in a bowl of diluted Physan20 (1 Tbsp / Gallon). I put about 10 in each container, hence 20 containers). I placed the lid on each container and placed it in the corner (moderate daylight/sun from the window). Every day I looked at the outside of each and could tell that they still adequately wet. I did this about 1 week ago.

Tonight I looked through the bottom of one and could tell that several were sprouting. I opened it to see how they looked and found that two had tiny white fibrous fuzz growing on them (looks like cotton candy, only white).

I'm not sure how to progress here. I'm also not sure if I should preemptively change all 20 containers, or just wait to see if they also get a fungus.

Should I:

Soak these seeds in diluted Physan20 again? If so, how long? I suppose I would then rinse the containers and put in fresh paper towels?

Should I do this now to all 200 seeds?

Or, should I throw them in dirt now?

Any help would be greatly appreciated. I have read most every thread here on how to grow, but I don't recall ever seeing a discussion of fungus.

Sorry about the lack of clarity in the pics - my camera would only focus on the recycling marking or the dishtowel underneath the container.


Follow-Up Postings:

 o
RE: Growing Clivia from seed - HELP! Fungus

That looks like normal, first root hairs. They look great.


 o
RE: Growing Clivia from seed - HELP! Fungus

Thank you, monet! I have only seen mature roots and was not aware they even grow "root hairs."

Thank you so much -- what a relief!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Clivia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here