Return to the Moss, Ferns & Cryptogams Forum | Post a Follow-Up

 o
Japanese Painted fern problem....

Posted by bgaviator 6 (My Page) on
Tue, May 7, 13 at 11:15

I just planted two Japanese painted ferns last week, and on one of them I am noticing light brown tips on the fronds. Is this a sign of too much water? I stuck my finger in the dirt, and it still feels moist. I have stopped watering it, and it doesn't seem to be getting any worse, nor any better. Any thoughts? Thanks.


Follow-Up Postings:

 o
RE: Japanese Painted fern problem....

The brown tips will stay on the fronds, the tissue is dead and won't recover. If the problem's still there the brown will keep spreading. You need to check on new growth to see if the plant is definitely back to normal growth.

The problem could also be chemical, something in the water, soil, or fertiliser if you've used any. Another problem could be low humidity levels.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Moss, Ferns & Cryptogams Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here