Return to the Moss, Ferns & Cryptogams Forum | Post a Follow-Up

 o
splaying Lady Fern

Posted by teri2 7B TN (My Page) on
Wed, Jul 31, 13 at 11:02

Is this normal? Over a few days my 3rd year beautiful Lady totally laid down. I tied it upright fairly easily, though. This year, I'm blaming all my garden issues on our seriously wet summer (47" so far) but I'm not sure about this. Any thoughts? TIA


Follow-Up Postings:

 o
RE: splaying Lady Fern

Too much nitrogen maybe.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Moss, Ferns & Cryptogams Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here