Return to the Moss, Ferns & Cryptogams Forum | Post a Follow-Up

 o
IDing fern ...Pictures added

Posted by whippet_lovers region 5 (My Page) on
Wed, Jul 25, 07 at 13:54

Hi! I was able to add pics of the fern! But, I may have made an error in using follow-up on my original post. No one will know they are there. Please someone have a peek, and see if you can help me out...
Thanks Ya'all!


Follow-Up Postings:

 o
RE: IDing fern ...Pictures added

Ok, I'm sorry to say I don't know what they are, but I'm sure someone will. You can also post pictures on the Name that Plant forum (use your same links) if you don't get a response here in a few days:

Fern #1

Fern #2


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Moss, Ferns & Cryptogams Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here