Return to the Dahlia Forum | Post a Follow-Up

 o
Dahlia flower rot

Posted by kojakwa 8WA (My Page) on
Tue, Mar 2, 10 at 13:46

My friend has plants that when the plants get to flower stage the flower pod up and dies does not open then it rots. Could this be caused by thrips or maybe something else? He has a friend on each side of him who have no problem with there dahalias.
By the way I am not the one with the rot problem.
Will this problem effect the tubers and give the same problem if dug and planted someplace else?


Follow-Up Postings:

 o
RE: Dahlia flower rot

Check out botrytis blight. This fungus may be the culprit. I've had this happen with buds on plants. Don't remember this happening last year, though, with my 'Unwins'(only ones I have). Humid conditions -- and probably rainy stretches -- caused buds to rot.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Dahlia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here