Return to the Dahlia Forum | Post a Follow-Up

 o
Mid-month update

Posted by sturgeonguy 5a ON (My Page) on
Mon, Jul 14, 08 at 20:28

Well, the beds are progressing...albeit slowly...but then many people seem to be having the same problem (ok, not VikingCraftsman or JRoot, but others.)

Here's my 3rd installment in my twice monthly pics. Click on any of the pics and see a slideshow of 11 pics.

I've finally got a bloom in my 100+ bed, I was getting worried that none would ever bloom there.

Check out the rest of my recently added pics, which includes a blooming 4' canna and my twin peaks, a pair of blooming yuccas, my grapes (which are finally going to give me tons of grapes), the smoke bush and more.

Cheers,
Russ


Follow-Up Postings:

 o
RE: Mid-month update

  • Posted by jroot 5A Ont. Canada (near (My Page) on
    Tue, Jul 15, 08 at 20:09

I got three of the 11 shots to show. The others seemed to be stuck, or maybe it is me being impatient. :)

Nice idea for showing though. Thanks Russ.


 o
RE: Mid-month update

Hopefully its you...;-] I just tried it again and it works, but I have a pretty fast connection so it could be the size of the pictures on a slower link.

Cheers,
Russ


 o
RE: Mid-month update

Russ - when did you plant them out? I was delayed by a back problem - planted out in mid to late June, but mine seem to be as tall as yours. Maybe they are slow this year? And as an aside - my garden is silent this year - no bees - very disturbing. I have become so used to their activity, it's almost lonely without them.

Anna


 o
RE: Mid-month update

My earliest cutting was taken on 2/28, for tubers I carried over from last year. Lots, however, came from tubers that were new for me this year. Those tubers didn't arrive until March, and cuttings came from April and beyond.

I know that I didn't give them enough light as cuttings, something I am working on for next year.

I totally agree that they seem slow this year. We've had thunderstorms on a regular (e.g. every couple of days) basis, but I'm also convinced I haven't received much water as a result. Meanwhile, I've kept my sprinklers off, so I do think I have deprived mine of enough water. Hopefully, next week, this will be resolved and I plan on giving them a few weeks of "good" watering in the hopes this will make a difference. We'll see.

FWIW, every one that has bloomed, has gone gangbusters as soon as the first flower was cut off. Not sure what that means, but its interesting.

Cheers,
Russ


 o
RE: Mid-month update

Just realized I didn't really answer your question, Anna.

My lakeside beds were planted out the last week of May. (Link to pics)

My roadside bed was planted out the last week of June. (Link to pics)

The only reason for the different dates was because I was selling cuttings up to the middle of June, so I didn't know what I would have left over for the roadside bed.

That being said, my lakeside beds are on the north side of the house, and while they get sun all day, they don't get as much as the roadside beds get. Also, my sprinkler system hasn't been working yet this year, so they haven't gotten as much water as I think they should have. That should be fixed next week.

Cheers,
Russ


 o
RE: Mid-month update

  • Posted by jroot 5A Ont. Canada (near (My Page) on
    Fri, Jul 18, 08 at 11:29

I have watered the dahlias every day ( early in the morning) , unless there is a heavy rain. I think that it was the last few days of May that I planted, but I did start them earlier under florescent lamps, and had them outside in pots most of May, taking them back into the garage when cold threatened.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Dahlia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here