Return to the Dahlia Forum | Post a Follow-Up

 o
blossoms not opening?

Posted by lily51 (My Page) on
Mon, Jul 19, 10 at 21:51

I plant the annual "patio" dahlias, so I hope this is the right forum.

These are beautiful flowers, bloom all summer in many different colors. However, I have one problem with them.
This seems to happen each year with my dahlias..Not all blooms will open. Some buds stay closed, turn dark and seem to "rot". Other blooms on the plant open and are fine.
What's going on here?


Follow-Up Postings:

 o
RE: blossoms not opening?

Botrytis? Read here

Here is a link that might be useful: Cornell Plant clinic


 o
RE: blossoms not opening?

thanks so much...sounds like a real possibility, especially since my dahlias ar in the same bed every year, no other plants with them.

that's why I love garden web..helpful people, sharing people.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Dahlia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here