Return to the Dahlia Forum | Post a Follow-Up

 o
Dahlia's won't bloom

Posted by kapokfp Michigan (My Page) on
Mon, Aug 13, 07 at 10:06

Got some beautiful dahlia bulbs from a relative Washington State. I'm in Michigan.

Three years running I get beautiful bushy foliage but no blooms. I've tried planting them in 3 spots on my property--all full sun. I fertilize properly. Could it be possible I'm overwintering them incorrectly? I store them in a box in my basement.


Follow-Up Postings:

 o
RE: Dahlia's won't bloom

The only incorrect way to store dahlias is to lose them. LOL
If you have bushy foliage, then the problem might be too much nitrogen in your fertilizer or soil. Have you tried a fertilizer with a higher middle number? And a looow first number.(nitrogen) Mor-bloom (brand or equivalent)is one that I use.
Or, it could be that the cultivars you are trying to grow is a very late blooming one. Are they setting any buds at all?


 o
RE: Dahlia's won't bloom

They don't set any buds at all. I have a hunch it might be my soil, which is fairly acidic. It's an ongoing battle where I live as the soil is very sandy and acidic here. Next year I'll try fertilizing like you suggest, grannymarsh. Thanks.


 o
RE: Dahlia's won't bloom

  • Posted by jroot 5A Ont. Canada (My Page) on
    Sat, Aug 18, 07 at 6:26

Grannymarsh's recommendation is "right on". I fertilize every week with a fertilizer with a higher middle number. ( not too high, though ). I continue this until the end of August, and I stop fertilizing completely then. My dahlias this year are amazing. The higher middle number promotes the formation of buds.

One thing else to consider. Do you have your dahlias in a place where they get a lot of sun? They are much less likely to bloom without it.

Perhaps you'll get some yet. The summer is not over for another month, although as I write the temperature outside has dipped to 8 degrees C.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Dahlia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here