Return to the Fragrant Plants Forum | Post a Follow-Up

 o
'John Smith' Begonia - still waiting for fragrance

Posted by robert1971 7a OK (My Page) on
Sat, Jul 7, 12 at 9:47

My 'John Smith' Begonia is still alive (knock on wood).
I've killed two 'Sunrise Scentiment' tuberous begonias already!
I changed out John's soil into a modified gritty mix and so far so good. The flowers continue to develop but I've yet to catch any scent from them. :(
Hopefuly I got the right tuber and I won't over water it like I did with the other ones!

-Robert

DanielWeeks7_1_12001


Follow-Up Postings:

 o
RE: 'John Smith' Begonia - still waiting for fragrance

Hi Robert!

How accurate is the color in your photo above? I ask because it doesn't look anything like the 'John Smith' I had last year, which was more of a solid peach with no variation in color throughout the petals. There was no pink anywhere. For me, the strong fragrance was even evident in the unopened buds which had started to color up, even with my allergy-ridden nose.

I hope they didn't send you the wrong tuber! :-(


 o
RE: 'John Smith' Begonia - still waiting for fragrance

Ispahan! You're back! ;)
The color is not accurate. It is more peachy (the pink/red was the same with the camera and my cell phone...go figure).
Still I suppose it could be the wrong plant which of course would be a major bummer considering I paid $64 altogether!
I suppose I'll wait until it opens further before sending an email to White Flower Farm.

So tell us what you've been growing! I know you're holding out on us. ;)

-Robert


 o
RE: 'John Smith' Begonia - still waiting for fragrance

Hi Robert,

I still check in periodically to see what is happening, but I have been busy participating in other forums.

I don't want to take over your thread, bu I have been enjoying lots of garden lilies this summer. The trumpets and Orienpets have been swooningly fragrant :-)


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fragrant Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here