Return to the Fuchsia Forum | Post a Follow-Up

 o
deformed leaves

Posted by cali_poppy_52 z10 CA/Sunset22 (My Page) on
Thu, Sep 2, 04 at 16:52

Every year my fuchsias are fine until all of a sudden the leaves get deformed and i have to prune them all.
What is this? Mites? It doesn't look like there are any on them.


Follow-Up Postings:

 o
RE: deformed leaves

Hi Deb,
Looks very much like Gall Mite. Check out F.A.Q on the Fuchsia Forum. Kath has posted a lot of info and a picture. Hope this will help.
IanS


 o
RE: deformed leaves

That's it, alright! It really makes a mess of those poor plants! Thanks very much!

-Deb


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fuchsia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here