Return to the Fuchsia Forum | Post a Follow-Up

 o
Is my Fuchsia dying?

Posted by mrbladedude 7 (My Page) on
Mon, May 7, 12 at 12:45

The flowers have started to die and fall off. The leaves have also gotten lighter since I got the plant. It looks like its sun deprived. Here are some pictures I took of the plant the day I got it and pictures of the plant now 2 weeks later.

Day I got the plant:

http://i959.photobucket.com/albums/ae73/rc3mil/DSCF2728.jpg

http://i959.photobucket.com/albums/ae73/rc3mil/DSCF2726.jpg

Today, 2 weeks later. Plant still hanging in same spot. Gets morning sun between 9:00 and 10:30 and then a tiny bit of dilapidated sun around 18:00.

http://i959.photobucket.com/albums/ae73/rc3mil/DSCF2924.jpg

http://i959.photobucket.com/albums/ae73/rc3mil/DSCF2926.jpg

Is this normal?

Thank you


Follow-Up Postings:

 o
RE: Is my Fuchsia dying?

Firstly it is normal for the flowers to eventually fade and fall off. They don't last forever. But the browning is perhaps not optimal. What is the temperature like where you are, has it been chilly at all? And when you bought the plant had it been hardened off to outdoor conditions. The other possibility is overwatering. That could cause the browning and also the leaf blanching.


 o
RE: Is my Fuchsia dying?

It has been a little chilly. Mostly 60's but now its 70's from now on. I took it back to the Nursery I got it from and they said to water the hell out of it. So I brought it home and did just that. I also pulled off all the dead leaves/flowers. Now there are pink and purple "pods" growing on the plant. The plant itself is still alive. Think it will just re flower?


 o
RE: Is my Fuchsia dying?

Remove the seed pods. You want the plant to keep flowering, not go to seed. It will rebloom if you deadhead it.


 o
Someone please help me!!!

I got two fuschia plants from Walmart. Repotted them in hanging baskets three weeks later I fertilized them and now the bottom of the main shoots coming out of the root ball are turning brown and none of my blooms are opening. Theirs alot of buds on them but their not opening. The temps have been between 60 at night and 90 durning the day. I have been watering them every three days. I have them facing north so they get the evening sun. I live in Missouri not sure what's happening to them any help would be great. Thanks ahead of time


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fuchsia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here