Return to the Fuchsia Forum | Post a Follow-Up

 o
please someone help me

Posted by matthook none (My Page) on
Tue, Jun 12, 12 at 20:13

i got two fuschia plants from walmart repotted them in hanging baskets.Three weeks later i fertilizied them and now the main shoots are turning brown some of the leaves are dead and none of the buds are blooming. they still have alot of buds on them but they dont open. The temps have been between 60 at night and 90 during the day i have been watering them every three days. i have them facing north so they get the evening sun. i live in missouri not sure whats happening to them. any help would be great!!! thanks ahead of time


Follow-Up Postings:

 o
RE: please someone help me

Our temps are no where near that warm, and I have to water my fuschia baskets every 2-3 days. Are the fuschias wilting? Fuschia like cool weather. A few leaves dying is no big deal. The main shoots turning brown (but not limp) might be the older stems getting woody, which is a good thing...that's what survives past the first year. Buds not opening could have several reasons...not enough water, or watering inconsistently, too much heat, possibly too much fertilizer (or other chemicals)at one time, insects, fungi, bacteria...the list goes on and on. Could you post a picture? It might be possible that they aren't getting enough light, too. We have more daylight than you, and if I put my plants on the north side of the house, I have to move them back to the west side after a while to get them to keep blooming.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fuchsia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here