Return to the Fuchsia Forum | Post a Follow-Up

 o
Help

Posted by zyperiris Seattle (My Page) on
Mon, Jun 3, 13 at 23:04

SOOOO I overwintered my Fuschias..and then I fertilized them and I have lots of green and no flowers. What to do?


Follow-Up Postings:

 o
RE: Help

What type of fertilizer did you use? Overwintered fuchsias are a little slow to get started compared to ones you find in nurseries. No matter, they will catch up and fairly rapidly too. Just make sure you have a bloom encouraging fertilizer - the second number should be the highest. LIke 0-10-10 or 15-30-15. And use a liquid/water soluble product diluted to half strength once a week.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Fuchsia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here