Return to the Gesneriad Forum | Post a Follow-Up

 o
Streptocarpus help

Posted by jeremy39 none (My Page) on
Sun, Jul 6, 14 at 19:43

Hi everyone im hoping someone can help me.
I've been a Gesneriad grower for some time now and lately I've noticed something strange happening to my Streptocarpus plants. Its even starting to happen to my seedlings that are under dome's as well. im not sure what is going on.The symptoms are that the younger leaves start turning brown and leathery killing the leaves entirely can someone identify what this is? I grow under lights in the basement I water once a week, I use a very well drained soil lots of vermiculite. I'm not sure if this is root rot, fungus ..etc. Please any advice would be helpful. Im scared im going to lose my babies.

This post was edited by jeremy39 on Sun, Jul 6, 14 at 20:00


Follow-Up Postings:

 o
RE: Streptocarpus help

another


 o
RE: Streptocarpus help

  • Posted by dbarron Z6/7 (Oklahoma) (My Page) on
    Fri, Jul 11, 14 at 21:50

I can only say I saw the same indoors during the winter with unfavorable environmental conditions (like too hot and too low humid). When conditions changed (aka turned house heating off), my plants became lovely again.
I also had a problem with the plants not growing actively so had to decrease my watering at the time as I was getting waterlogged roots.

This post was edited by dbarron on Fri, Jul 11, 14 at 21:51


 o
RE: Streptocarpus help

Jeremy, a few observations and questions.

From the picture of your plants in the first photo I can see salt build up around the rim of the pot. I do not believe this the only cause but it will not help.

You say you use a well drained soil with lots of vermiculite. Do you add perlite to your soil?

What is the ratio of soil, perlite, vermiculite?

My biggest concern with your soil is a lot of vermiculite. Vermiculite does help with drainage but also helps retain water in the mix. My best guess here without knowing humidity levels and temps is your plants are too wet and the conditions are creating a perfect environment for fungus and rot. It appears your soil is retaining salts which maybe building up and causing dieback.

Do you have air movement? A small fan in the growing area?

How often do you repot?

Dave


 o
RE: Streptocarpus help

Hi Dave,

Thank you for replying to my post.

To answer your questions..

I use 2 parts Perlite to 1 part African violet mix then I add a half cup of vermiculite just for extra drainage.

I grow in the basement under lights and I have a very dry basement, however for air movement I use an air purifier on the high setting so it gives the plants some air movement. I water once a week with plan water and once every 2 months with food.

I repot every year but most of my plants are still babies. I have over 2 hundred different Streps and im afraid this will get worse. I also grow hundreds of African violets in the same basement and they do wonderfully.

I don't see the salt build up you see in the pictures. What am I dong wrong?

This post was edited by jeremy39 on Sun, Jul 13, 14 at 0:57


 o
RE: Streptocarpus help

Jeremy, the brown crust around the edge of the pot is the salt build up. Over time it is normal. Could it be you have aphids or worse thrips? They are usually under leaves and in crowns so check there.

From what you are telling me everything sounds right. Vermiculite is not too much and should have no affect on the plants.

This has me leaning more to a pest problem. The only other advice I can give if not pests are present is try the same potting mix ratio without the vermiculite and see if there is a difference. Try only on a few plants and watch carefully. My email is strepbystrep@gmail.com. If you have any other questions.

One other thought, how long are your lights on for? What type T--12, T-8, etc. how far are the plants from the lights and for how long?

Dave


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Gesneriad Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here