Return to the Ornamental Grasses Forum | Post a Follow-Up

 o
hardy pampas

Posted by buddman 5 (My Page) on
Tue, Jun 26, 07 at 11:08

I put in several starter plants I purchased locally 4 or 5 years ago. They did great. Multiplied and grew to 12 to 14 feet. I was out in the yard on Sunday and I think all but a recent addition have died. What could have happened? I detected some signs of field mice. Could they have diseased the plants or destroyed the roots?


Follow-Up Postings:

 o
RE: hardy pampas

  • Posted by donn_ 7a, GSB, LI, NY (My Page) on
    Thu, Jun 28, 07 at 7:16

It's hard to diagnose without photos and more detail. Did they just die overnight, or was it a long process? I've heard of nesting/digging rodents destroying grasses by damaging the crown, but I don't think it's an immediate process.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Ornamental Grasses Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here