Return to the Groundcovers Forum | Post a Follow-Up

 o
is my wintergreen dead?

Posted by cateyanne zone 5 ohio (My Page) on
Mon, Apr 23, 07 at 20:31

I planted some wintergreen/tea berry ground cover last fall. Now I keep looking at it and it isn't doing anything. It is a combination of rusty red leaves and brown. Does anyone know when this starts to come back and what it looks like. Am I being too impatient? I'll be very upset if it didn't make it. Please advise.


Follow-Up Postings:

 o
RE: is my wintergreen dead?

  • Posted by kkbix z5 Indy (My Page) on
    Fri, Apr 27, 07 at 13:12

I live in central Indiana and my Wintergreen look the same way. They should start to grow again soon. The late freeze hurt them some. I would not worry yet.


 o
RE: is my wintergreen dead?

Thanks! I'm glad there's still hope!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Groundcovers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here