Return to the Groundcovers Forum | Post a Follow-Up

 o
Speedwell Georgia Blue not flowering ???

Posted by brit5467 7b VA East Coast (My Page) on
Wed, May 12, 10 at 20:25

Wondering what's going on with my Speedwell? Bought 6 of them - healthy, blooming nicely in 4" pots. Planted them randomly in my raised bed but -- after the existing blooms fell off, they've never bloomed again. They're about 2 mos. old or so old and spreading nicely (however, not very fast). The 'tag' said spring & summer bloomer.

SO WHERE ARE MY PRETTY BLUE FLOWERS???

The nursery (not where I bought them) said to give them a 'haircut' so I did that to 3 on one side and left the other 3 alone, as to compare results since they're in the same sunlight conditions on both sides. Didn't seem to make a difference, except that the ones I left alone have spread more.

The soil is new, nice and fertile and everything else is taking off in leaps and bounds. I've feed them with fertilizer made to encourage blooms (also suggested by the nursery) but that hasn't helped.

Any ideas ???

Tks,
Bonnie aka brit5467


Follow-Up Postings:

 o
RE: Speedwell Georgia Blue not flowering ???

  • Posted by kayskats 7 (usda) 8 (arbor da (My Page) on
    Thu, Jul 1, 10 at 13:43

not a regular here ... so just saw this

I have two types of Speedwell (Ga Blue and something else and I'm no longer sure which is which) but both bloom profusely in the spring with only random blooms off and on later.

I like this groundcover because it spreads quickly ... but after a few years I find I have to drastically cut it back, but it holds up to Maryland winters better than ajuga which I also love.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Groundcovers Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here