Return to the Harvest Forum | Post a Follow-Up

 o
trouble with new All American canner

Posted by jeanwedding 6 ky (My Page) on
Sun, Sep 4, 11 at 18:42

First time used it other day. Got up to the 10 lbs on gauge and it jiggled lightly off and on like book said. But the gap when closing could not make even....
Trued to use it an today instead of Presto which only holds 5qts.....
So opted for the new 21 qt all American canner.
I even asked Hubby to try to even up the gap to make uniform.. He could not even after trying four times. course it was hot to touch...
So let it go anyway. Steam leaked from both handles......
Gauge got up to 8 lbs. regulator Jigglier never really jiggled. Processed it anyway.. like over 25
ANOTHER thing there is no ARROW on bottom. Only a DIMPLE.......anyone else have a dimple rather than the arrow???


Follow-Up Postings:

 o
RE: trouble with new All American canner

ANOTHER thing there is no ARROW on bottom. Only a DIMPLE.......anyone else have a dimple rather than the arrow???

Don't know what you mean by this part of your question.

Putting on the lid requires setting it on and slightly tightening down alternate handles at the same time - the ones across from each other - until all are evenly tightented down.

Per the instruction manual:

To secure the
cover, gradually and evenly tighten two
opposite wing nuts at the same time,
maintaining the same size gap around
the entire unit where the cover meets the
bottom. Never tighten just one wing
nut at a time. A new cooker will
sometimes leak slightly around the
metal-to-metal seal. This will do no
harm, and should cease after being used
a few times.

Make sure you have properly lubed the lid with Vaseline as per the instructions before using.

Dave


 o
RE: trouble with new All American canner

We dont understand how to make the gap even . Tried gobs 0f times. Can not even it out. Some spots it almost touches...
yes read and knew all the other....
In a youtube video the lady shows her 21 qt canner. Her bottom part has an "arrow" MIne has a DIMPLE Only the lid has an arrow..........
Said to align the arrows in book and the utube video..
Thanks
Jean


 o
RE: trouble with new All American canner

I would write the company and ask about not having the arrow. I know you line them up.
Did you put Vaseline on the rim of the canner before you put the lid on ?? You need to do that.

That is one reason I stick with my Presto. I don't want to mess with those handles. Each has their own preference in canners, though.


 o
RE: trouble with new All American canner

This is a NEW canner right? Then there sure should be the arrow mark there somewhere. But even if not the lid can really only go on one way that allows the small latch to slide around and under the lip and still allow the knobs to line up.

The issue with not getting the gap even comes from tightening down the first set of knobs too much. Just lightly tighten @12 and 6, then lightly tighten 10 and 4, and then the lastat 8 and 2. Then go back and do the same again until all are tightened down.

Dave


 o
RE: trouble with new All American canner

Mine has a sort of triangle shaped indentation. I would not call it an "arrow" but I know what it is for. It looks nothing like the arrow on the lid.

As to getting the lid level, if you are having that much trouble it sounds like something is not right. Normally they are very easy to get level, and the only way you can't is if you tighten it lopsided. Though you will have about 1/4" to 3/8" gap all the way around once tightened on. That is how it's suppose to be.


 o
RE: trouble with new All American canner

The first time you use your All American pressure cooker you will probably have to loosen the black wing nuts/knobs a little by turning them backwards. Sometimes they are put on too tightly at the manufacturers. If they are on too tight it makes the screw too short to fasten over the lid.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Harvest Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here