Return to the Hellebore Forum | Post a Follow-Up

 o
Early Blooms

Posted by gardenwitch 7 Va (My Page) on
Mon, Dec 20, 04 at 20:59

My Pine Knot Strain Hellebore was in full bloom last week. I have never had such early blooms and wondered if it was a result of moving the plant in the fall from container to garden.I know we have had some very mild weather up till yesterday but no one else around me has any blooms.


Follow-Up Postings:

 o
RE: Early Blooms

My 3 year old foetidus began blooming for the first time a couple of weeks ago. Other areas of the US are seeing unseasonable blooms too.


 o
RE: Early Blooms

I moved some the other way, from garden to container (potted up divisions) and I have several of them starting to flower now.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hellebore Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here