Return to the Heuchera Forum | Post a Follow-Up

 o
Fire Alarm & Leaf Mold

Posted by GGardens 8 (My Page) on
Sat, May 4, 13 at 14:36

My brand new (3 wks old) Fire Alarm seems to be infected with some kind of leaf mold spore -- dark spots appear on the top side of the leaf and green mold spores on the under side, then the leaf dies. Should I remove the plant so that my other huechera don't get infected--any treatment recommended, any hope to save the plant? New leaves are appearing consistently.


Follow-Up Postings:

 o
RE: Fire Alarm & Leaf Mold

Have you tried cutting off the leaves that appear affected before they die off? I don't know if it would be effective, but would be the first thing I would think to do


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Heuchera Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here