Return to the Hibiscus Forum | Post a Follow-Up

 o
What the heck is causing this?

Posted by paul_ z5 MI (My Page) on
Sun, Jul 22, 12 at 16:24

The leaves on a number of branches on the RoS at my folks place are really a mess. Not sure just what is causing it -- no sign of mites, caterpillars, powdery mildew or such ....

July 2012


Follow-Up Postings:

 o
RE: What the heck is causing this?

This is a long-shot, Paul, but it reminds me the way herbicide drift affects tomato plants. Is that a possibility? Otherwise, I'm sure some of the RoS experts can help you.

Good luck.

Gary


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here