Return to the Hibiscus Forum | Post a Follow-Up

 o
Hibiscus desease?

Posted by orchid_elaine (My Page) on
Sun, Jul 13, 08 at 21:03

My hibiscus has bloomed non stop from Jan. to May in a pot in my sun room. Now many of the leaves have brown and yellow areas that eventually spread to half the leaf. The leaf withers and falls off. Does anyone know what causes it? I don't see any insects.I'd like to display a picture but I don't know how to do that.


Follow-Up Postings:

 o
RE: Hibiscus desease?

what do you do for fertilizer?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here