Return to the Hibiscus Forum | Post a Follow-Up

 o
Bugs on satin blue hibiscus

Posted by cgcomeaux louisiana (My Page) on
Thu, Jul 26, 07 at 21:29

My satin blue hibiscus has not been blooming any flowers it did a couple times, but then stoped. I also noticed some little bugs growing on the buds, and buds will not bloom.Here is a pic can you tell what this is and how to treast it.
http://i183.photobucket.com/albums/x295/cgcomeaux/DSC00294.jpg


Follow-Up Postings:

 o
RE: Bugs on satin blue hibiscus

Hi.
Your picture shows Aphids.I have them too on my Rose of Sharon buds,I spray the plant with dish detergent and water
5 ml.of detergent to 1L.of water.It works.
Hala.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here