Return to the Hibiscus Forum | Post a Follow-Up

 o
Hibiscus buds not blooming

Posted by breadvan 10 FLA (My Page) on
Thu, Aug 7, 14 at 16:06

Lots of green with no punch. I can't seem to figure out why I have loads of buds on my bushes and just when they appear like they are about to bloom, the buds just fall off with no bloom, I feed them organic hibiscus fertilizer, occasional iron, and Florida summers produce adequate rain.


Follow-Up Postings:

 o
RE: Hibiscus buds not blooming

if the flowers are just about to bloom and then die, you might try treating for thrips. or if hte buds are still small and turn yellow it might be Gall midge. Check the Hidden Valley Hibiscus website for how to treat...


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here