Return to the Hibiscus Forum | Post a Follow-Up

 o
Hybiscus cutting

Posted by Hrihori none (My Page) on
Mon, Aug 26, 13 at 17:29

Two years ago after pruning we took a cutting with 3 leaves and placed it into a water glass. After two years it has lost one leaf but now it is producing a flower, There are no roots showing. We change the water once a month and wash off the algae. Since this cutting is a survivor is there any way to pot it?

Greg


Follow-Up Postings:

 o
RE: Hybiscus cutting

Why have you not planted this Hibiscus already. You do not have to wait for roots to form and 2 years is way too long. It should have been in a pot a couple years ago.


 o
RE: Hybiscus cutting

thats a bit odd that there are no roots. i took a small cutting and put it in water. it did grow roots....but was also using a rooting hormone. it is also recommended to cut away a bit of the outer layer to expose the inner stem where the roots will grow from.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here