Return to the Hibiscus Forum | Post a Follow-Up

 o
My Hibiscus is not doing well : (

Posted by teenytina78 NY (My Page) on
Tue, Oct 24, 06 at 23:27

I just got my first Hibiscus and planted it inside. It flowered for about a month and then the leaves turned yellow and fell off. On about three to four of the branches the tips are slightly covered with spider like web. I don't see any bugs on it at all, shook it for white flies and did not find any. I sprayed Sevin on it twice. I watered the soil directly at first but it stayed moist all the time and these bugs were crawling in the soil so I started watering the bottom (I have a self watering pot). The bugs went away. The leaves are seemed to be "ripped" or have irregular sides that have smooth edges. I have a sun lamp on it for a few hours a day. Please help. Thank you!!


Follow-Up Postings:

 o
RE: My Hibiscus is not doing well : (

Hi teenytina,

Sounds like red spider to me. Very difficult to control so you may as well forget it. Red spiders produce a web but they are so tiny, you will need a magnifying glass to see them. They love dry conditions so if you see this again, you must mist regularly but it may already be too late.


 o
RE: My Hibiscus is not doing well : (

Tina, did you toss the plant? Mites are pests, but they can be killed..If the tree isn't too large take to sink or shower and spray w/water..do this 3 times a wk. Also, buy a mister and spray daily..Add 2-4 drops of dish soap to water.
Since I don't use harsh chemicals I count on the dish soap which works fine. Toni


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here