Return to the Hibiscus Forum | Post a Follow-Up

 o
Alyogyne hueglii Help

Posted by hornetwife Memphis z7 (My Page) on
Tue, Dec 11, 07 at 10:17

Hello,
I have an Alyogyne hueglii (Australian hibiscus?) and it has spider mites! Can anyone give me info on how to treat for spider mites on this since is has fuzzy leaves? I washed it down really good in the sink and ever since, it has been drooping and wilting. Can anyone help?
Thanks in advance!
Lori

Here is a link that might be useful: Wilting and Dying


Follow-Up Postings:

 o
RE: Alyogyne hueglii Help

  • Posted by bboy z8 WA USA (My Page) on
    Tue, Dec 18, 07 at 18:26

Apparently you battered it somehow, maybe spraying too hard. This shouldn't kill the whole plant. If it's definitely dying maybe something else is going on, like root rot or chemical injury - did you use detergent on it?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hibiscus Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here