Return to the Hoya Forum | Post a Follow-Up

 o
I've got BLOOMS!

Posted by there_and_back_again none (My Page) on
Mon, Jun 9, 14 at 12:31

One of the little barely-rooted babies I got back in March or so decided to bloom for me! I've been keeping a close eye on the peduncle as I noticed it developing, thinking the buds would surely blast, but they didn't, and they were open this morning when I checked on them! This is labeled Hoya limoniaca, but I'm curious if anyone else has/had blooms to compare it to.

 photo HoyaLimoniaca1.jpg


Follow-Up Postings:

 o
RE: I've got BLOOMS!

Congrats, T&BA! My limoniaca has yet to bloom, so I have no photos to compare to. I'm hoping this might be the year. You must be doing something right as I've had mine since 2009!

Denise in Omaha


 o
RE: I've got BLOOMS!

I have to say, I am pretty shocked. It was nothing but a stick with teeny tiny hair-like roots. I was a bit peeved, because these were supposed to be well-established plants, but you know how that goes. It's barely put on any leaves or vines, but I suspect that's because it is putting all the energy into making the flowers.


 o
RE: I've got BLOOMS!

Congrats on blooming!

If you do a search on limoniaca, I know there are pics of both the flowers and leaves on this forum, and you can compare. It's hard to tell for sure from your picture, but it looks like it could be. Just compare both flowers and leaves.

I've found limoniaca to be a good grower and bloomer, it pretty much blooms all summer long for me.

Renee


 o
RE: I've got BLOOMS!

Very pretty! Congratulations on your early blooms. I'm sure it will get growing eventually and you will be able to relax.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hoya Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here