Return to the Hoya Forum | Post a Follow-Up

 o
blooms

Posted by mschie1013 none (My Page) on
Fri, Aug 3, 12 at 20:02

So, when I returned from my vacation I was thrilled to see that my Krimson Queen had buds. This is the same plant (given to me by a friend) that I had difficulty with over the winter. It hasn't bloomed at all this season. My question for you all is how long does it usually take before flowers bloom? I have had these buds at least 6 days with no evidence that they are even beginning to open.

Your advice is sure appreciated!
Michelle


Follow-Up Postings:

 o
RE: blooms

My carnosas have buds on them for weeks before they bloom!
xo
kittee


 o
RE: blooms

Thanks for the info, Kittee. Now I won't be as disappointed because they haven't opened. I'll give them more time.

Michelle


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hoya Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here